Cookie Consent Tool

Cookie Consent Tool

Version:

Free
Free

Support by shopware AG

Source Available
599 Downloads
Responsive
Shopware 6: Plugin status Shopware 6 Signet
There will be no Shopware 6 successor for this plugin. The functionalities of this plugin are already included in Shopware 6
    Swag183769231668f
  • 1.6.4
  • 18 Dec 2019
  • de_DE en_GB
  • from shopware AG (only with commercial shopware version)
  • 5.2.11 – 5.2.27
    5.3.0 – 5.3.7
    5.4.0 – 5.4.6
    5.5.0 – 5.5.10
    5.6.0 – 5.6.2
On 1 October 2019, the European Court of Justice ruled that end users must give explicit and... more

Product information

On 1 October 2019, the European Court of Justice ruled that end users must give explicit and active consent before an online shop can place cookies on their device. However, according to Paragraph 15, Section 3 of the German Telemedia Act (TMA), this does not apply to data collected under anonymous profiles for advertising purposes. Here the user must only have the opportunity to object to the use.


With this Cookie Consent Tool, you can extend your current cookie settings in Shopware 5 and correctly set up your shop to comply with the new requirements in accordance with the ECJ ruling.


After installing and activating the plugin, your customers are able to to view/edit the following cookie settings in a clear & user-friendly menu:

  • Individually accept or reject each cookie
  • Cookies that are technically mandatory are displayed separately and cannot be edited
  • Reject / accept all cookies, depending on setting
  • All cookies that are not allowed are automatically removed


Manufacturer of the plugin is shopware. The github repository can be found here:    https://github.com/shopwareLabs/SwagCookieConsentManager


5.6.3:Shopware

As of Shopware 5.6.3, the Cookie Consent Tool is included in the Shopware core as a standard function. This can be maintained via the advanced cookie settings.

Github repository: https://github.com/shopwareLabs/SwagCookieConsentManager

Show full description

Highlights

  • Plugin for securely complying with the ECJ ruling on consent for cookies
  • Easy to adjust settings and activate the plugin in your storefront
  • Very strong usability for the end customer

Features

  • The customer can individually accept or reject each cookie
  • Cookies that are technically mandatory are displayed separately and cannot be edited
  • Reject/accept all cookies, depending on the setting
  • All cookies that are not allowed are automatically removed
Read, write and discuss reviews... more

Customer reviews

Average customer rating from 1 reviews:

Total (1)
Functionality
Usability
Documentation
Support

Warum entwickelt Shopware ein Plugin, das für den eigenen Shop nicht kompatibel ist?

20 Mar 2020

Es wird mir angezeigt, dass das Plugin für meinen Shop nicht kompatibel ist. Ich fahre ein Update von 5.6.2 auf 5.6.6 und kann das Showare-eigene, wichtige Plugin nicht mehr verwenden? Stattdessen bleibt der Bildschirm nach dem Update leer???

Was macht das für einen Sinn?

Total
Functionality
Usability
Documentation
Support
shopware AG
23 Mar 2020

Hallo Markus,
vielen Dank für die Bewertung und das Feedback zu unserem Plugin.

Die Funktion des Cookie Consent Tool auf Grundlage des zum 01. Oktober 2019 gefällten Urteils zur Einwilligung bei Cookies hinzugefügt wurde, ist diese Funktion in den Shopware-Versionen ab 5.6.3 bereits im Core enthalten. Das Plugin wurde geschaffen, um auch Shopbetreibern mit älteren Shopware-Versionen die Möglichkeit zu bieten, die Funktionen nutzen zu können. Die Installation des Plugins ist in neueren Versionen also nicht mehr erforderlich, hierauf weisen wir auch ausdrücklich in der Beschreibung des Plugins hin.

Viele Grüße aus Schöppingen
Dein Team der shopware AG

Installation manual

Depending on the version, Shopware 5 gives you various options for activating and using the Cookie Consent Tool.


Shopware 5.6.3:

As of Shopware 5.6.3, the Cookie Consent Tool is included in the Shopware core as a standard function.

Changelog

Version 1.6.4

- All technically necessary cookies are now always active

- Changed cookie group of the SLT cookie

- Added sorting of cookies

- Added validity check of cookie preferences


Version 1.5.3

- All technically necessary cookies are now always active

- Changed cookie group of the SLT cookie

- Added sorting of cookies

- Added validity check of cookie preferences


Version 1.4.3

- All technically necessary cookies are now always active

- Changed cookie group of the SLT cookie

- Added sorting of cookies

- Added validity check of cookie preferences


Version 1.3.3

- All technically necessary cookies are now always active

- Changed cookie group of the SLT cookie

- Added sorting of cookies

- Added validity check of cookie preferences


Version 1.2.3

- All technically necessary cookies are now always active

- Changed cookie group of the SLT cookie

- Added sorting of cookies

- Added validity check of cookie preferences


Version 1.1.3

- All technically necessary cookies are now always active

- Changed cookie group of the SLT cookie

- Added sorting of cookies

- Added validity check of cookie preferences


Version 1.0.3

- All technically necessary cookies are now always active

- Changed cookie group of the SLT cookie

- Added sorting of cookies

- Added validity check of cookie preferences


Version 1.6.3

Adjusted the Regex for the shop cookie

Version 1.5.2

Adjusted the Regex for the shop cookie

Version 1.4.2

Adjusted the Regex for the shop cookie

Version 1.3.2

Adjusted the Regex for the shop cookie

Version 1.2.2

Adjusted the Regex for the shop cookie

Version 1.1.2

Adjusted the Regex for the shop cookie

Version 1.0.2

Adjusted the Regex for the shop cookie

Version 1.6.2

Fixed issue with uninstalling the plugin

Version 1.6.1

Renamed wrong namespaces for compatibility reasons

Version 1.5.1

Renamed wrong namespaces for compatibility reasons

Version 1.4.1

Renamed wrong namespaces for compatibility reasons

Version 1.3.1

Renamed wrong namespaces for compatibility reasons

Version 1.2.1

Renamed wrong namespaces for compatibility reasons

Version 1.1.1

Renamed wrong namespaces for compatibility reasons

Version 1.0.1

Renamed wrong namespaces for compatibility reasons

Version 1.6.0

Compatible with Shopware 5.6.0 to 5.6.2.

Version 1.5.0

Compatible with Shopware 5.5.0 to 5.5.10.

Version 1.4.0

Compatible with Shopware 5.4.6.

Version 1.3.0

Compatible with Shopware 5.4.0 to 5.4.5.

Version 1.2.0

Compatible with Shopware 5.3.5 to 5.3.7.

Version 1.1.0

Compatible with Shopware 5.3.0 to 5.3.4.

Version 1.0.0

Compatbile with Shopware 5.2.11 to 5.2.27.

About the manufacturer

shopware AG shopware AG Shopware Enterprise Partner Shopware Enterprise Partner 77 Extensions 3.5 Ø Rating

Version:

Free
Free

Support by shopware AG

Recently viewed