Heidelpay Payment plugin

Heidelpay Payment plugin

by customweb no ratings yet Source Available 14 Downloads
Current version:

Version:

€ 29.00 * / per month

Cancelable monthly

This plugin is available for Shopware 6
Expected release: Jul 2020
Support
This manufacturer responds very quickly to support requests
Plugin details
  • Cwb8a1f5cf71fa12m
  • customweb
  • 5.6.3.0.61
  • 28 Jul 2020
  • de_DE en_GB es_ES fr_FR it_IT
  • 5.3.0 – 5.3.7
    5.4.0 – 5.4.6
    5.5.0 – 5.5.10
    5.6.0 – 5.6.7
Heidelpay Accept credit card payments as well as other payment methods such as debit cards... more

Product information

Heidelpay

Accept credit card payments as well as other payment methods such as debit cards (PostFinance, etc.), eWallets (PayPal, etc.) and web-banking payment methods (PostFinance E-Finance, sofortüberweisung, ELV/giropay, iDeal, etc) and many more in your Shopware shop with no big effort.

The Shopware Heidelpay Payment Plugin supports the authorisation methods IFrame, Hidden, Server and Payment Page.

The Shopware Heidelpay Payment Plugin also supports capturing and refund. This means that you can process payments directly from the administration interface of the shop and no longer have to log into the back-end of Heidelpay. This simplifies the payment processing a lot.

Payment Methods

This plugin of customweb supports the following payment methods:

  • Credit Card               
  • Debit Card               
  • American Express               
  • BarPay               
  • Carte Bleue               
  • Lastschrift               
  • EPS               
  • giropay               
  • iDEAL               
  • Open Invoice               
  • Maestro               
  • MangirKart               
  • MasterCard                
  • PayPal               
  • Postepay               
  • Prepayment                
  • Sofortüberweisung               
  • Solo Card               
  • Visa               
  • JCB               
  • Diners Club               
  • Discover Card               
  • PostFinance E-Finance               
  • PostFinance Card               
  • Przelewy24               
  • Yapital               
  • MasterPass

Features

This plugin supports the following features:

  • iFrame Authorization: Process payments without redirection. Payment form loaded within an IFrame (fully PCI DSS SAQ A compliant authorization). 
  • Hidden Authorization: Process payments without redirection via a seamless integration (requires PCI DSS SAQ A-EP).
  • Server Authorization: Process payments without redirection via a seamless integration (requires PCI DSS SAQ A-EP).
  • Payment Page: Your customers will be redirected to a payment page to process the payment. 
  • Transaction Management: Create and issue credit notes directly from your shop.
  • Subscription: This plugin is compatible with the shopware Abo Commerce.
  • Alias Manager / Token System: Save credit card data (PCI-compliant storage) during the payment process.
  • External Checkout.

Migration

If you have previously installed the plugin via the Sellxed Store (https://www.sellxed.com/shop) we have a detailed Installation Instruction (https://www.sellxed.com/de/blog/sellxed-plugins-im-shopware-marketplace) that shows you how to migrate to the marketplace version. 


Show full description Show less
Read, write and discuss reviews... more

Customer reviews

Changelog

Version 5.4.3.0.61

Payment Beans: Icepay update fulfilment description

Version 5.5.3.0.61

Payment Beans: Icepay update fulfilment description

Version 5.6.3.0.61

Payment Beans: Icepay update fulfilment description

Version 5.3.3.0.61

Payment Beans: Icepay update fulfilment description

Version 5.5.3.0.60

Removed unused files which did not adhere to PSR-0 namespace guidelines.

Version 5.3.3.0.60

Removed unused files which did not adhere to PSR-0 namespace guidelines.

Version 5.4.3.0.60

Removed unused files which did not adhere to PSR-0 namespace guidelines.

Version 5.6.3.0.60

Removed unused files which did not adhere to PSR-0 namespace guidelines.

Version 5.6.3.0.59

Fixed issue with Belarusian Ruble (BYR 974 => BYN 933)

Version 5.5.3.0.59

Fixed issue with Belarusian Ruble (BYR 974 => BYN 933)

Version 5.3.3.0.59

Fixed issue with Belarusian Ruble (BYR 974 => BYN 933)

Version 5.4.3.0.59

Fixed issue with Belarusian Ruble (BYR 974 => BYN 933)

Version 5.6.3.0.58

Allows changing birth date form element label.

Version 5.3.3.0.58

Allows changing birth date form element label.

Version 5.5.3.0.58

Allows changing birth date form element label.

Version 5.4.3.0.58

Allows changing birth date form element label.

Version 5.3.3.0.57

Added support for Shopware 5.6.7

Version 5.6.3.0.57

Added support for Shopware 5.6.7

Version 5.4.3.0.57

Added support for Shopware 5.6.7

Version 5.5.3.0.57

Added support for Shopware 5.6.7

Version 5.5.3.0.56

Skip country check in prevalidation if country is not set.

Version 5.6.3.0.56

Skip country check in prevalidation if country is not set.

Version 5.3.3.0.56

Skip country check in prevalidation if country is not set.

Version 5.4.3.0.56

Skip country check in prevalidation if country is not set.

Version 5.5.3.0.55

Fix incorrect date time calculations.

Version 5.3.3.0.55

Fix incorrect date time calculations.

Version 5.4.3.0.55

Fix incorrect date time calculations.

Version 5.6.3.0.55

Fix incorrect date time calculations.

Version 5.5.3.0.54

Update certificate bundle

Version 5.4.3.0.54

Update certificate bundle

Version 5.6.3.0.54

Update certificate bundle

Version 5.3.3.0.54

Update certificate bundle

Version 5.3.3.0.53

5.6.6 release where not available yet.

Version 5.5.3.0.53

5.6.6 release where not available yet.

Version 5.4.3.0.53

5.6.6 release where not available yet.

Version 5.6.3.0.53

5.6.6 release where not available yet.

Version 5.6.3.0.52

Handle EntityNotFoundExceptions if entity manager cannot find entity.

Version 5.3.3.0.52

Handle EntityNotFoundExceptions if entity manager cannot find entity.

Version 5.5.3.0.52

Handle EntityNotFoundExceptions if entity manager cannot find entity.

Version 5.4.3.0.52

Handle EntityNotFoundExceptions if entity manager cannot find entity.

Version 5.5.3.0.51

Fix issue where warning would be generated instead of exception if entity could not be loaded.

Version 5.6.3.0.51

Fix issue where warning would be generated instead of exception if entity could not be loaded.

Version 5.4.3.0.51

Fix issue where warning would be generated instead of exception if entity could not be loaded.

Version 5.3.3.0.51

Fix issue where warning would be generated instead of exception if entity could not be loaded.

Version 5.5.3.0.50

Fixed issue with ratepay identifier.

Version 5.3.3.0.50

Fixed issue with ratepay identifier.

Version 5.6.3.0.50

Fixed issue with ratepay identifier.

Version 5.4.3.0.50

Fixed issue with ratepay identifier.

Version 5.4.3.0.49

Fix SameSite cookie policy issues.

Version 5.5.3.0.49

Fix SameSite cookie policy issues.

Version 5.3.3.0.49

Fix SameSite cookie policy issues.

Version 5.6.3.0.49

Fix SameSite cookie policy issues.

Version 5.5.3.0.48

Add transactionId to the email context. The variable can be used within email templates now (also for 5.6.x).

Version 5.3.3.0.48

Add transactionId to the email context. The variable can be used within email templates now (also for 5.6.x).

Version 5.6.3.0.48

Add transactionId to the email context. The variable can be used within email templates now (also for 5.6.x).

Version 5.4.3.0.48

Add transactionId to the email context. The variable can be used within email templates now (also for 5.6.x).

Version 5.3.3.0.47

Add transactionId to the email context. The variable can be used within email templates now.

Version 5.5.3.0.47

Add transactionId to the email context. The variable can be used within email templates now.

Version 5.4.3.0.47

Add transactionId to the email context. The variable can be used within email templates now.

Version 5.6.3.0.47

Add transactionId to the email context. The variable can be used within email templates now.

Version 5.6.3.0.46

Ensure that invalid language codes do not create errors.

Version 5.4.3.0.46

Ensure that invalid language codes do not create errors.

Version 5.5.3.0.46

Ensure that invalid language codes do not create errors.

Version 5.3.3.0.46

Ensure that invalid language codes do not create errors.

Version 5.6.3.0.45

Improved checksum handling to allow some leeway for proxies.

Version 5.5.3.0.45

Improved checksum handling to allow some leeway for proxies.

Version 5.3.3.0.45

Improved checksum handling to allow some leeway for proxies.

Version 5.4.3.0.45

Improved checksum handling to allow some leeway for proxies.

Version 5.6.3.0.44

Fix deprecation warnings for PHP 7.4

Version 5.5.3.0.44

Fix deprecation warnings for PHP 7.4

Version 5.3.3.0.44

Fix deprecation warnings for PHP 7.4

Version 5.4.3.0.44

Fix deprecation warnings for PHP 7.4

Version 5.5.3.0.43

Removed access to array using curly braces in UTF8 helper (deprecated as of PHP 7.4)

Version 5.3.3.0.43

Removed access to array using curly braces in UTF8 helper (deprecated as of PHP 7.4)

Version 5.6.3.0.43

Removed access to array using curly braces in UTF8 helper (deprecated as of PHP 7.4)

Version 5.4.3.0.43

Removed access to array using curly braces in UTF8 helper (deprecated as of PHP 7.4)

Version 5.6.3.0.42

Fix deprecation warning under Windows for PHP 7.1

Version 5.3.3.0.42

Fix deprecation warning under Windows for PHP 7.1

Version 5.4.3.0.42

Fix deprecation warning under Windows for PHP 7.1

Version 5.5.3.0.42

Fix deprecation warning under Windows for PHP 7.1

Version 5.3.3.0.41

Improved IP address handling.

Version 5.6.3.0.41

Improved IP address handling.

Version 5.5.3.0.41

Improved IP address handling.

Version 5.4.3.0.41

Improved IP address handling.

Version 5.5.3.0.40

Fix correctTaxRate to differentiate null and zero.

Version 5.6.3.0.40

Fix correctTaxRate to differentiate null and zero.

Version 5.4.3.0.40

Fix correctTaxRate to differentiate null and zero.

Version 5.3.3.0.40

Fix correctTaxRate to differentiate null and zero.

Version 5.6.3.0.39

Convert language code 'bp' to 'pt'.

Version 5.4.3.0.39

Convert language code 'bp' to 'pt'.

Version 5.5.3.0.39

Convert language code 'bp' to 'pt'.

Version 5.3.3.0.39

Convert language code 'bp' to 'pt'.

Version 5.3.3.0.38

Use vatId as salesTaxNumber automatically where supplied.

Version 5.4.3.0.38

Use vatId as salesTaxNumber automatically where supplied.

Version 5.5.3.0.38

Use vatId as salesTaxNumber automatically where supplied.

Version 5.6.3.0.38

Use vatId as salesTaxNumber automatically where supplied.

Version 5.5.3.0.37

Fixes issue with invoice items

Version 5.6.3.0.37

Fixes issue with invoice items

Version 5.3.3.0.37

Fixes issue with invoice items

Version 5.4.3.0.37

Fixes issue with invoice items

Version 5.5.3.0.36

Set customer's device type on order.

Version 5.6.3.0.36

Set customer's device type on order.

Version 5.3.3.0.36

Set customer's device type on order.

Version 5.4.3.0.36

Set customer's device type on order.

Version 5.3.3.0.35

Fixes issue with controllers

Version 5.6.3.0.35

Fixes issue with controllers

Version 5.5.3.0.35

Fixes issue with controllers

Version 5.4.3.0.35

Fixes issue with controllers

Version 5.5.3.0.34

Fixes issue with datetime object

Version 5.6.3.0.34

Fixes issue with datetime object

Version 5.3.3.0.34

Fixes issue with datetime object

Version 5.4.3.0.34

Fixes issue with datetime object

Version 5.3.3.0.33

Improved manual and updated test data

Version 5.6.3.0.33

Improved manual and updated test data

Version 5.5.3.0.33

Improved manual and updated test data

Version 5.4.3.0.33

Improved manual and updated test data

Version 5.6.3.0.32

Removed duplicate "Starfield Services Root Certificate Authority - G2"

Version 5.5.3.0.32

Removed duplicate "Starfield Services Root Certificate Authority - G2"

Version 5.4.3.0.32

Removed duplicate "Starfield Services Root Certificate Authority - G2"

Version 5.3.3.0.32

Removed duplicate "Starfield Services Root Certificate Authority - G2"

Version 5.5.3.0.31

Various fixes and improvements

Version 5.6.3.0.31

Various fixes and improvements

Version 5.3.3.0.31

Various fixes and improvements

Version 5.4.3.0.31

Various fixes and improvements

Version 5.4.3.0.30

Fix a bug in the datetime handler.

Version 5.3.3.0.30

Fix a bug in the datetime handler.

Version 5.5.3.0.30

Fix a bug in the datetime handler.

Version 5.4.3.0.29

Fixed possible warning, improved datetime handling.

Version 5.5.3.0.29

Fixed possible warning, improved datetime handling.

Version 5.3.3.0.29

Fixed possible warning, improved datetime handling.

Version 5.3.3.0.28

Skip payment method prevalidation if not in checkout controller.

Version 5.4.3.0.28

Skip payment method prevalidation if not in checkout controller.

Version 5.5.3.0.28

Skip payment method prevalidation if not in checkout controller.

Version 5.3.3.0.27

Improved error message during ip extraction, fixed ipv6 validation.

Version 5.4.3.0.27

Improved error message during ip extraction, fixed ipv6 validation.

Version 5.5.3.0.27

Improved error message during ip extraction, fixed ipv6 validation.

Version 5.3.3.0.26

Fixes possible NPE in external checkout

Version 5.5.3.0.26

Fixes possible NPE in external checkout

Version 5.4.3.0.26

Fixes possible NPE in external checkout

Version 5.3.3.0.25

Fix issue with missing currency in amount comparison function.

Version 5.4.3.0.25

Fix issue with missing currency in amount comparison function.

Version 5.5.3.0.25

Fix issue with missing currency in amount comparison function.

Version 5.4.3.0.24

Javascript improvements.

Version 5.5.3.0.24

Javascript improvements.

Version 5.3.3.0.24

Javascript improvements.

Version 5.4.3.0.23

Better filter for guest checkouts for aliases.

Version 5.3.3.0.23

Better filter for guest checkouts for aliases.

Version 5.5.3.0.23

Better filter for guest checkouts for aliases.

Version 5.4.3.0.22

Added setting on order context, isAjaxReloadRequired. This flag may be used to indicate if a javascript object requires a refresh before submission.

Version 5.3.3.0.22

Added setting on order context, isAjaxReloadRequired. This flag may be used to indicate if a javascript object requires a refresh before submission.

Version 5.5.3.0.22

Added setting on order context, isAjaxReloadRequired. This flag may be used to indicate if a javascript object requires a refresh before submission.

Version 5.3.3.0.21

Updatd certificate bundle

Version 5.5.3.0.21

Updatd certificate bundle

Version 5.4.3.0.21

Updatd certificate bundle

Version 5.3.3.0.20

Initiate refund if failed transaction succeeds - ensure shop status is correct.

Version 5.4.3.0.20

Initiate refund if failed transaction succeeds - ensure shop status is correct.

Version 5.5.3.0.20

Initiate refund if failed transaction succeeds - ensure shop status is correct.

Version 5.3.3.0.19

Updated manuals and test data

Version 5.4.3.0.19

Updated manuals and test data

Version 5.5.3.0.19

Updated manuals and test data

Version 5.5.3.0.18

Fix URL builder for subshops.

Version 5.4.3.0.18

Fix URL builder for subshops.

Version 5.3.3.0.18

Fix URL builder for subshops.

Version 5.5.3.0.17

Updated phpsecurity library to newest version

Version 5.4.3.0.17

Updated phpsecurity library to newest version

Version 5.3.3.0.17

Updated phpsecurity library to newest version

Version 5.5.3.0.16

Fixes issue with Abocommerce

Version 5.4.3.0.16

Fixes issue with Abocommerce

Version 5.3.3.0.16

Fixes issue with Abocommerce

Version 5.4.3.0.15

Migrated jQuery to new domain and updated URL

Version 5.3.3.0.15

Migrated jQuery to new domain and updated URL

Version 5.5.3.0.15

Migrated jQuery to new domain and updated URL

Version 5.3.3.0.14

Fixed issue with & / & translations.

Version 5.5.3.0.14

Fixed issue with & / & translations.

Version 5.4.3.0.14

Fixed issue with & / & translations.

Version 5.3.3.0.13

Fixes issue with multiple active plugins on some servers.

Version 5.4.3.0.13

Fixes issue with multiple active plugins on some servers.

Version 5.5.3.0.13

Fixes issue with multiple active plugins on some servers.

Version 5.3.3.0.12

Fixes PHP deprecation warnings

Version 5.5.3.0.12

Fixes PHP deprecation warnings

Version 5.4.3.0.12

Fixes PHP deprecation warnings

Version 5.4.3.0.11

Refactor the way the Abo Commerce plugin is integrated so that a direct usage of the recurring feature is more easy.

Version 5.5.3.0.11

Refactor the way the Abo Commerce plugin is integrated so that a direct usage of the recurring feature is more easy.

Version 5.3.3.0.11

Refactor the way the Abo Commerce plugin is integrated so that a direct usage of the recurring feature is more easy.

Demo

German

Frontend Demo
Backend Demo
Name demo@customweb.ch Password test1234

English

Frontend Demo
Backend Demo
Name demo@customweb.ch Password test1234

About the manufacturer

customweb customweb Shopware Technology Partner Shopware Technology Partner 42 Extensions 3.5 Ø Rating
Current version:

Version:

€ 29.00 * / per month

Cancelable monthly

Recently viewed